SCAU:18067 字符统计

2023-12-15 19:37:05

18067?字符统计

时间限制:1000MS? 代码长度限制:10KB
提交次数:0 通过次数:0

题型: 填空题???语言: G++;GCC;VC

Description

编写一个函数,统计一个字符串中字母、数字和空格的个数。使用全局变量存放字母和数字个数,函数返回值是空格个数

#include?<stdio.h>
#include?<string.h>
#include?<math.h>

int?nL=0,?nN=0;

int?statistics(char?*s)
{
????_______________________
}

int?main()
{
????char?s[81];
????int?nS;
????gets(s);
????nS?=?statistics(s);

????printf("%d?%d?%d\n",?nL,?nN,?nS);
????return?0;
}

?

输入格式

输入一行字符,以'\n'符结束

输出格式

统计结果

输入样例

Ab 45

输出样例

2 2 1
#include <stdio.h>
#include <string.h>
#include <math.h>

int nL=0, nN=0;

int statistics(char *s)
{
    int n=0;
    while(*s!='\0')
    {

        if(*s>='a'&&*s<='z'||*s>='A'&&*s<='Z')
        nL++;
        if(*s>='0'&&*s<='9')
        nN++;
        if(*s==' ')
        n++;
        s++;
    }
    return n;
}

int main()
{
    char s[81];
    int nS;
    gets(s);
    nS = statistics(s);

    printf("%d %d %d\n", nL, nN, nS);
    return 0;
}

?

文章来源:https://blog.csdn.net/zero_019/article/details/135021833
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。