大一C语言作业题目2
2023-12-22 14:27:30
7-2 找出总分最高的学生
给定N个学生的基本信息,包括学号(由5个数字组成的字符串)、姓名(长度小于10的不包含空白字符的非空字符串)和3门课程的成绩([0,100]区间内的整数),要求输出总分最高学生的姓名、学号和总分。
输入格式:
输入在一行中给出正整数N(≤10)。随后N行,每行给出一位学生的信息,格式为“学号 姓名 成绩1 成绩2 成绩3”,中间以空格分隔。
输出格式:
在一行中输出总分最高学生的姓名、学号和总分,间隔一个空格。题目保证这样的学生是唯一的。
输入样例:
5
00001 huanglan 78 83 75
00002 wanghai 76 80 77
00003 shenqiang 87 83 76
10001 zhangfeng 92 88 78
21987 zhangmeng 80 82 75
输出样例:
原先代码:
#include<stdio.h>
#include<string.h>
struct Student {
?? ?char Id[5];
?? ?char Name[10];
?? ?int A;
?? ?int B;
?? ?int C;
};
int max(Student stu[],int N){
?? ?int max =stu[1].A+stu[1].B+stu[1].C;
?? ?int i ;
?? ?int sum;
?? ?int j = 0;
?? ?for(i=0;i<N;i++){
?? ??? ?sum = stu[i].A+stu[i].B+stu[i].C;
?? ??? ?if(max<sum){
?? ??? ??? ?max=sum;
?? ??? ??? ?j++;
?? ??? ?}
?? ?}
?? ?return j;
}
int main(){
?? ?int N;
?? ?scanf("%d",&N);
?? ?
?? ?struct Student stu[N];
?? ?int i;
?? ?for(i=0;i<N;i++){
?? ?scanf("%s %s %d %d %d\n",stu[i].Id,stu[i].Name,&stu[i].A,&stu[i].B,&stu[i].C);
?? ?}
?? ?int j ;
?? ?j =max(stu,N);
?? ?int max =stu[j].A+stu[j].B+stu[j].C;
?? ?printf("%s %s %d\n",stu[j].Name,stu[j].Id,max);
?? ?return 0;
?? ?
?? ?
}
修改后的代码:
#include<stdio.h>
#include<string.h>
struct Student {
char Id[6];//
char Name[10];
int A;
int B;
int C;
};
int max(struct Student stu[],int N){//
int max =stu[0].A+stu[0].B+stu[0].C;//
int i ;
int sum;
int index = 0;
for(i=0;i<N;i++){
sum = stu[i].A+stu[i].B+stu[i].C;
if(max<sum){
max=sum;
index = i;
}
}
return index;
}
int main(){
int N;
scanf("%d",&N);
struct Student stu[N];
int i;
for(i=0;i<N;i++){
scanf("%s %s %d %d %d",stu[i].Id,stu[i].Name,&stu[i].A,&stu[i].B,&stu[i].C);//
}
int index ;
index =max(stu,N);
int max =stu[index].A+stu[index].B+stu[index].C;
printf("%s %s %d\n",stu[index].Name,stu[index].Id,max);
return 0;
}
几个注意事项:
1、字符串要多留一位。
char Id[6];
2、调用非既定的,要写出struct
int max(struct Student stu[],int N){}
3、?我原先写的j,是不对的。因为这样子的加加,是没有考虑到如果中间有没有比max大的数字的时候,那之后别人的加加就不是对应求它的索引了。我一开始想着加加就可以求得索引值。
scanf("%s %s %d %d %d",stu[i].Id,stu[i].Name,&stu[i].A,&stu[i].B,&stu[i].C);//
4、scanf不需要写\n?
文章来源:https://blog.csdn.net/2301_80185446/article/details/135151323
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。 如若内容造成侵权/违法违规/事实不符,请联系我的编程经验分享网邮箱:veading@qq.com进行投诉反馈,一经查实,立即删除!
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。 如若内容造成侵权/违法违规/事实不符,请联系我的编程经验分享网邮箱:veading@qq.com进行投诉反馈,一经查实,立即删除!