AcWing刷题(循环语句)------C语言版
2023-12-13 03:58:48
1.(708)偶数:
编写一个程序,输出?11?到?100100?之间(包括?11?和?100100)的全部偶数。
输入格式
无输入。
输出格式
输出全部偶数,每个偶数占一行。
输入样例
No input
输出样例
2
4
6
...
100
运行代码:
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int x;
for(int x=1;x<=100;x++)
{
if(x%2==0)
{
cout<<x<<endl;
}
}
return 0;
}
2.(709)奇数:
输入一个整数?X,输出?11?到?X?之间(包括?11?和?X)的全部奇数。
输入格式
一个整数?X。
输出格式
输出所有满足条件的奇数,每个数占一行。
数据范围
1≤X≤1000
输入样例:
8
输出样例:
1
3
5
7
运行代码:?
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int x,y;
cin>>y;
for(int x=1;x<=y;x++)
{
if(x%2!=0)
{
cout<<x<<endl;
}
}
return 0;
}
3.(710)6个奇数:
读取一个整数?X,输出?X之后的?66?个奇数,如果?X?也是奇数,那么它也算作?66?个奇数之一。
输入格式
一个整数?X。
输出格式
所有满足条件的奇数,每个占一行。
数据范围
1≤X≤100
输入样例:
9
输出样例:
9
11
13
15
17
19
运行代码:
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{ int x, y;
cin >> y;
for (int x = y; x <=y+11; x++)
{
if (x % 2 != 0)
{
cout << x << endl;
}
}
return 0;
}
4.(711)乘法表
输入格式
一个整数?N。
输出格式
输出?N?的乘法表,具体形式参照输出样例。
数据范围
1<N<1000
输入样例:
140
输出样例:
1 x 140 = 140
2 x 140 = 280
3 x 140 = 420
4 x 140 = 560
5 x 140 = 700
6 x 140 = 840
7 x 140 = 980
8 x 140 = 1120
9 x 140 = 1260
10 x 140 = 1400
运行代码:
#include<cstdio>
#include<iostream>
using namespace std;
int main ()
{
int x,j;
cin>>x;
for(int y=1;y<=10;y++)
{
printf("%d x %d = %d",y,x,y*x);
printf("\n");
}
return 0;
}
5.(712)正数:
输入格式
六个数字,每个占一行。
输出格式
输出格式为?x positive numbers
,其中?x�?为正数的个数。
数据范围
输入数字的绝对值不超过?100100。
输入样例:
7
-5
6
-3.4
4.6
12
输出样例:
4 positive numbers
运行代码:
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
float x;
int l=0;
for(int i=1;i<=6;i++)
{
cin>>x;
if(x>=0)
{
l++;
}
}
cout<<l<<" positive numbers"<<endl;
return 0;
}
6.(713)区间2:
输入格式
第一行包含整数?N,表示共有?N个整数需要进行判断。
接下来?N行,每行包含一个整数?X。
输出格式
第一行输出?x in
,其中?x?为在范围内的整数的数量。
第二行输出?y out
,其中?y为在范围外的整数的数量。
数据范围
1≤N≤100001≤≤10000,
?107<X<107
输入样例:
4
14
123
10
-25
输出样例:
2 in
2 out
运行代码:
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int n;
int in=0;
int out=0;
cin>>n;
for(int j=1;j<=n;j++)
{
int x;
cin>>x;
if(x >= 10 && x <= 20)
{
in++;
}
else
{
out++;
}
}
printf("%d in\n",in);
printf("%d out",out);
return 0;
}
文章来源:https://blog.csdn.net/2301_80898911/article/details/134900819
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。 如若内容造成侵权/违法违规/事实不符,请联系我的编程经验分享网邮箱:veading@qq.com进行投诉反馈,一经查实,立即删除!
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。 如若内容造成侵权/违法违规/事实不符,请联系我的编程经验分享网邮箱:veading@qq.com进行投诉反馈,一经查实,立即删除!